Kbase P120226: A record is not available when using FIND statement via ODBC DataServer with UDB/400
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  3/12/2008 |
|
Status: Unverified
FACT(s) (Environment):
OS/400 V5R3
ODBC DataServer
OpenEdge 10.1A
SYMPTOM(s):
A record is not available when using FIND statement via ODBC DataServer with UDB/400
OpenEdge 10.1A ODBC Wire Protocol driver for DB2 v.5.10.00.24
i5/OS PTF Level (5722SS1): TC04209
Running a 4GL query to check record availability multiple times returns correct results only twice and the third time the same record is no longer available
The third instance of SQLExecute succeeds but there are no rows in a result set to fetch:
EXIT SQLFetch with return code 100 (SQL_NO_DATA_FOUND)
The symptoms are consistent and can be reproduced at will
The issue doesn't occur on the i5/OS at the PTF level TC05298
CAUSE:
The Data Direct DB2 ODBC driver doesn't get expected result from the AS/400 Database Server. The problem is related to an iSeries issue resolved by one of IBM's latest PTFs
FIX:
Apply cumulative Corrective Service Package PTF C5298530