Kbase P102117: User count for a remote server growing > then maximum # of users for a remote server - port scanner
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  26/08/2010 |
|
Status: Verified
SYMPTOM(s):
Server's received count <n> does not equal client(<n>)'s send count <n>. (1055)
Total user count in activity screen of promon differs from total users connected thru servers screen in R&D
Port Scanning being done against ports Progress Database Brokers are listening on.
Progress 9.1D09 is where the problem occurs.
Remote users cannot connect to a remote server.
User count associated with a server is incrementing even though a user is not connected to the server process.
User count is above maximum # of users (-Ma) for a server.
Progress ports being scanned by a port scanner.
No pending users in promon -> R&D -> Status -> Server detail screen
Prior to Progress 9.1D09, the user count would not get incremented when scanned by the port scanner.
Sudden degradation of performance on database server
Users unable to connect to database
No servers are available. Try again later. (1154)
Error reading socket=<n> ret=<n> errno=<n>. (795)
Error reading socket=220 ret=-1 errno=10055. (795)
FACT(s) (Environment):
OpenEdge 10.x
Progress 9.1D
Progress 9.1D 64-bit
Progress 9.1x
All Supported Operating Systems
CAUSE:
We were incorrectly incrementing the user count when a port scanner was used to scan our ports.
CAUSE:
Bug# OE00113830
FIX:
Upgrade to 9.1E02 or later.
Upgrade to 10.0B02 or later.
Upgrade to 10.1A.
Workaround:
If an upgrade is not possible at the current time, then ensure that the port scanning software application excludes all ports used by Progress.