Consultor Eletrônico



Kbase P119422: Report Engine fails with SQL Engine error after Netsetup installation on OpenEdge 10
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/11/2006
Status: Unverified

FACT(s) (Environment):

OpenEdge 10.x
Windows

SYMPTOM(s):

Report Engine fails with error when trying to display/print reports

Unable to connect to database. Database error is:
Report Builder has detected that the SQL engine has shut down due to a database error.
Please save your report, exit and restart Report Builder.

Client PC has a Shared Network Installation of OpenEdge

OpenEdge 10 has been installed and configured correctly with netsetup (drive was not mapped to DLC root, settings in Registry are correct, etc.)

FileMon/RegMon logs show no obvious errors (correct files/keys are found and accessed)

Problem occurs when .PRL is located on the client PC or the server

Problem is only seen on client PCs

Reports can be generated correctly on the server

Same configuration works for Progress 9.1x

Using RBSTART.PF file to pass parameters to the Report Engine

Parameters in the RBSTART.PF are separated by commas, for example:

-inp 8000, -tok 1600

CAUSE:

The RBSTART.PF file should use the same format as a standard Progress .PF; parameters should not be separated with commas but with spaces/line-breaks. That this format working in Progress 9.1x appears to be a bug that was resolved in OpenEdge 10.x. It is not possible to comma-separate startup parameter in OpenEdge 10.

FIX:

Change the format of the RBSTART.PF file, removing any illegal character such as the comma. For example:

-inp 8000
-tok 1600