Consultor Eletrônico



Kbase P119116: Error 7128 occurs when calling an OpenEdge 10 procedure with Temp-Table as OUTPUT parameter from a P
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/6/2009
Status: Unverified

SYMPTOM(s):

Error 7128 occurs when calling an OpenEdge 10 procedure with Temp-Table as OUTPUT parameter from a Progress 9.1x ActiveX Open Client

Error (7128) when calling a 10.1A procedure with Temp-Table as OUTPUT parameter from a 9.1D07 ActiveX Open Client

Error (7128) when calling procedure with Temp-Table as OUTPUT parameter

com.progress.open4glError: System Error. (7128):System Error.(7128)

AppServer agent uses 100% of the CPU

Problem also occurs when passing a temp-Table as INPUT-OUTPUT parameter

.R files have been compiled in OpenEdge 10

FACT(s) (Environment):

Calling the procedure from a 9.1x ActiveX Open Client using Visual Basic
Connecting to a OpenEdge 10 AppServer
Error also appears with a Progress 9.1E ActiveX Open Client
Progress 9.1x
Windows

CAUSE:

The .R files have been compiled in OpenEdge 10. The ProxyGen accepts only Progress 9 .R files.

FIX:

Follow these steps below to fix the problem:

1) Compile the .R files in Progress 9
2) Regenerate the ActiveX proxy from ProxyGen