Consultor Eletrônico



Kbase P118900: WebClient application hangs or displays error when using AIA
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   16/10/2008
Status: Unverified

FACT(s) (Environment):

Progress 9.x
OpenEdge 10.x
WebClient

SYMPTOM(s):

WebClient application hangs when using AIA

WebClient application reports disconnection from server

Issue appears after application has been working properly for a while

AIA or web server reports that connection was terminated by client

HTTP client-to-server connections are automatically terminated by network operator when idle

CAUSE:

When possible, the WebClient application tries to use a persistent connection to the server for requests to the AIA. This persistent connection is negotiated at the first connection to the server, depending on the availability of the HTTP Keep-Alive feature on the web server. If the server advertises this feature and a persistent connection is established, then it is expected to hold until the client terminates the connection.
If the network forcefully closes a persistent connection established that way, then it creates an unexpected condition in the client application and the application can start to behave inconsistently. The most common symptom is hanging.

FIX:

The primary solution to this issue is to ensure that the network honors the persistent state of connections.
Under some circumstances, this cannot be ensured. In this case, the secondary solution is to prevent the negotiation of persistent connections altogether, by disabling the HTTP Keep-Alive feature on the web server. This can be done in several ways:
- for servers which allow to configure this feature directly, just disable the Keep-Alive feature.
- otherwise, force the use of the HTTP/1.0 protocol on the web server. HTTP/1.0 does not support Keep-Alive.