Kbase P118762: The Web Service Adapter times out when receiving a SOAP Request through Tomcat
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  9/15/2006 |
|
Status: Unverified
FACT(s) (Environment):
OpenEdge 10.1A
Web Services
Tomcat 4.1
SYMPTOM(s):
The Web Service Adapter times out when receiving a SOAP Request
The WSA times out when receiving a SOAP Request
Error unmarshalling SOAP Envelope: Read timed out (10956)
The SOAP request (id: 1d9) failed, stack trace level 0 (10941)
msg=Error in SOAP Envelope: Read timed out (10913); targetException=Read timed out]
Using Microsoft Biztalk as the Web Service client
Sending batches of 100 messages through Biztalk to the WSA
CAUSE:
The Web Service client (in this case Microsoft Biztalk) is taking too long to send the SOAP request.
FIX:
Increase the ?connectionTimout" property for the appropiate Connector in the <TOMCAT_Install>/conf/server.xml. For example, if you are using Tomcat's default port, then increase the timeout for the Connector which is listening on port 8080:
<Service className="org.apache.catalina.core.StandardService" debug="0" name="Tomcat-Standalone">
<Connector className="org.apache.coyote.tomcat4.CoyoteConnector" ... connectionTimeout="20000" ... port="8080" ...>
<Factory className="org.apache.catalina.net.DefaultServerSocketFactory"/>
</Connector>