Consultor Eletrônico



Kbase P118631: Some users receiving a 5175 error when connected to a database remotely.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   12/01/2009
Status: Verified

SYMPTOM(s):

Some users are receiving a 5175 error when connected to a database.

Registry error : Could not create the '' key for the Event Viewer. (5175)

Remote users experiencing the error are using a file server to access the client executables.

Environment variable EVTLEVEL is set to none on the server machine.

Process explorer shows that EVTLEVEL environment variable is not set for this clients session.

FACT(s) (Environment):

The key for the 5175 error is specific to a database connection.
Registry key has permissions for all local domain users to update the key the error occurs on.
Authenticated user added to registry key and 5175 error persists.
Only some remote users experience the error.
Local users connected in a remote manner do not receive the error.
Remote clients are not using a shared network installation.
File Server is the same machine as the database server machine.
Windows
Progress/OpenEdge Product Family

CAUSE:

Remote clients are accessing the client executables from a file server. The executable itself is running on the client machine. The EVTEVEL when set on the server will not be detected or utilized on the client.

FIX:

1. Add -evtlevel none to the command execution string or a parameter file being used by the client.

or

2. Set the environment variable EVTLEVEL to none on the clients machine.