Kbase P117394: Error (11773) when connecting to a Web Service when the NameServer's port is not 5162
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  05/02/2009 |
|
Status: Verified
SYMPTOM(s):
Error (11773) when connecting to a Web Service
Error receiving Web Service Response: HTTP status error: receive (11773)
When increasing the debugging level to extended, the following error appears in the WSA log file:
Error in SOAP request execution: Connect Failure: Timeout or Interrupt occurred while attempting to communicate with NameServer. (8231) (10926)
FACT(s) (Environment):
The NameServer is not using the default port of 5162
Executing the command "wsaman -i wsa1 -appname <Web Service name> -getprops" returns that the appServicePort is 5162.
OpenEdge 10.x
All Supported Operating Systems
CAUSE:
The port specified for the NameServer on the appServicePort property for the Web Service is not correct.
FIX:
The appServicePort property of the Web Service needs to be changed and refer to the correct NameServer's port.
The steps to follow are the following:
1- Disable the Web Service.
On UNIX, the command is:
wsaman -i wsa1 -appname <appfriendly-name> -disable
On Windows, this can be achieved from the Progress Explorer, by selecting the Web Service, and clicking on the Disable button (or right-click menu)
2- Change the appServicePort property of the Web Service.
On UNIX, the command is:
wsaman -i wsa1 -appname <appfriendly-name> -prop appServicePort -value <NameServer's port> -setprops
On Windows, this can be achieved from the Progress Explorer, by selecting the Web Service, and clicking on the Properties button (or right-click menu)
3- Enable the Web Service
On UNIX, the command is:
wsaman -i wsa1 -appname <appfriendly-name> -enable
On Windows, this can be achieved from the Progress Explorer, by selecting the Web Service, and clicking on the Enable button (or right-click menu)