Consultor Eletrônico



Kbase P117334: Cannot convert a version 9 database to OpenEdge 10 with conv910 error 11158
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   6/24/2008
Status: Verified

SYMPTOM(s):

Can not convert a version 9 database to OpenEdge 10

Proutil conv910 fails with error 11158

Internal error in upStatRecDump, errno 3. (11158)


Internal error in upSqlStatTblsDel, errno 2. (11158)


Internal error in drConv910, errno 4. (11158)

Database has SQL clients

Deleting all statistics records fails with error -1214

Internal error -1214 (see dsmret.h) in SQL from subsystem DSM SERVICES function dsmKeyDelete called from ix_delete on PUB._Sysidxstat for PUB._Idxsysidxstat.

FACT(s) (Environment):

Progress 9.x
OpenEdge 10.x

CAUSE:

The error indicates that the index in _sysidxstat is corrupt and this is causing the conv910 to fail. Different version numbers are assigned to sql stat table number in version 9. conv910 does not use table name and owner name to operate those tables as it operates during runtime.

CAUSE:

Bug# OE00097696

FIX:

Steps:

1. Restore the backup copy of the version 9 database prior to conv910

2. Rebuild _Sysidxstat index _Idxsysidxstat

$ proutil <dbname> -C idxbuild some -TB 24 -TM 32

Table name:
_Sysidxstat
Index name:
_Idxsysidxstat
Enter the name of table containing the index.
Enter ! to indicate input is complete. (9176)
Table name:
!
The following indexes will be rebuilt:
Owner: PUB
Table: _Sysidxstat
Index: _Idxsysidxstat
Is this correct? (y
)
y

3. Take a new backup of the version 9 database (Optional) or add these instructions to the migration instructions.

4. Change the environment variables to OpenEdge 10 ($DLC, $PATH) and run the conv910 utility, which will now complete without error.

$ proutil <dbname> - C conv910