Consultor Eletrônico



Kbase P116884: Client session disappears navigating part of application after applying Windows 2000 SP03
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   15/08/2006
Status: Verified

FACT(s) (Environment):

Windows NT 32 Intel/Windows 2000
Progress 9.1x

SYMPTOM(s):

Client sessions disappear when navigating application

Application may encounter a General Protection Fault

Error Prowin32.exe Has generated errors and will be closed by windows. You will need to restart the program. An error log is being created.

Prowin32.exe Application Error, The instruction at "<memory address>" referenced memory at "<memory address>". The memory could not be "written". Click on OK to terminate the program

User is terminated from Database log file

prow32!PROExceptionHandler::GetLogicalAddress

Usernum terminated abnormally. (794)

Application uses CSSPIN32.OCX

Problem does not occur with Service Pack 2 for Windows 2000.

CHANGE:

Installed Service Pack 3 on Windows 2000

CAUSE:

Bug# 20021209-009

CAUSE:

The CSSPin and CSCombo controls shipped with 9.1x and earlier do not function correctly on Windows 2000 SP3 or later.

FIX:

To resolve the problem, upgrade to a Progress version that contains the 4.50.0.0 version of CSCOMB32.OCX and CSSPIN32.OCX. To obtain the newer controls:

1) Upgrade to Progress 9.1E
2) Upgrade to OpenEdge 10
3) Contact Progress Support