Consultor Eletrônico



Kbase P116869: Unable to connect to database via DB Navigator, error message lists only the name of the driver
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   4/25/2008
Status: Verified

FACT(s) (Environment):

Windows
OpenEdge 10.1x

SYMPTOM(s):

Adding database into DB Navigator Connection Profiles page

Cannot connect to database

No error other than a dialog box which lists the name of the JDBC driver (com.ddtek.jdbc.openedge.OpenEdgeDriver)

In the JDBC Drivers section of the DB Navigator preferences there is no blue check mark next to the 'Progress OpenEdge 10.1 JDBC Driver'

When editing the 'Progress OpenEdge 10.1 JDBC Driver' the JAR files listed in the Extra Class Path tab contain '[[INSTALL-DIR]]' instead of a physical path name

CAUSE:

An unknown error happened during the installation of OpenEdge 10.1 which caused the path of the JAR files to not be entered into the Extra Class Path tab

FIX:

Remove the entries for the three JAR files (openedge.jar, base.jar and util.jar) from the Extra Class Path tab and re-add them (ensure that the fully qualified path and file name are used)