Consultor Eletrônico



Kbase P116728: Long start up time of Progress runtime in OpenEdge Architect
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/16/2008
Status: Unverified

FACT(s) (Environment):

OpenEdge 10.1x
Windows

SYMPTOM(s):

Progress runtime appears to hangs when Architect start

Several minutes before Progress runtime is ready in Architect

Status message "Fetching database schema" displays for more than a few seconds

Status message "Fetch schema" displays for more than a few seconds

Dialog box displays "The OpenEdge runtime is busy. Launch Pro*Tools cannot be performed at this time."

Dialog box displays "Progress session appears to be busy. Are you sure that you want to restart the session?"

Progress runtime is eventually ready to use.

CAUSE:

Architect cannot communicate properly with the Progress runtime. An external cause is preventing TCP/IP data exchange between Architect and the Progress runtime.

FIX:

Check the system environment and third party software.
Depending on the exact cause involved, solutions include:
- removing firewall rules for the local loopback interface (127.0.0.1)
- disabling anti-virus software checks for Architect and Progress utilities
- reinstalling the default Windows TCP/IP stack and drivers