Consultor Eletrônico



Kbase P99039: Graph cache attempting concurrent transactions message in admserv.log file
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   5/17/2007
Status: Verified

FACT(s) (Environment):

Fathom Management 3.0A

SYMPTOM(s):

Message in admserv.log file

Message:Graph cache attempting concurrent transactions.

Graph cache attempting to close a closed transaction

admserv.log file recording many exceptions to ads0.exp file

Exception: java.lang.OutOfMemoryError
Message (throw): Error polling resource.
Message (excp): null
Stack Trace: java.lang.OutOfMemoryError

Exception: com.odi.UpdateReadOnlyException
Message (throw): Error polling resource.
Message (excp): Attempt to make database modifications in a read-only transaction.
Stack Trace:
com.odi.UpdateReadOnlyException: Attempt to make database modifications in a read-only transaction.
at com.odi.imp.ObjectManager.assureTransactionCompatible(ObjectManager.java:4574)

Exception: com.progress.isq.ipqos.CacheDatabaseException
Message (excp): Graph cache attempting concurrent transactions.
Stack Trace: com.progress.isq.ipqos.CacheDatabaseException: Graph cache attempting concurrent transactions.at com.progress.isq.ipqos.CacheDatabase.beginCacheTransaction(CacheDatabase.java(Compiled Code))

CAUSE:

Bug# 20050503-004

CAUSE:

The Graph database has become locked. Although low settings of Java heap parameters for the AdminServer/Fathom contribute, they are not the sole cause. We have found that under certain circumstances, a dead lock can occur between the fathom db and the graph cache database. ie: a lock on the resource database while holding the graph data cache database lock.

FIX:

Apply Fathom Management 3.0A04 Service Pack (3.1A01 also has this fix) - paying special attention to the additional configuration steps needed in the readme.

The following Workaround recovers the situation:

0.) Stop the AdminServer on the Fathom machine

1.) Make sure that there are no "java.exe" still running, if they are, please kill them because these will be orphan one(s), due to java running out of the memory. Alternatively, reboot the machine.

2.) Increase the maximum heap size for JVMARGS from the default of 128MB:


For Progress 9 bound to the 3.0A Fathom Management:
UNIX: in the $DLC/java_env file under the particular OS heading in the JVMARGS section
WINDOWS: in the registry key HKEY_LOCAL_MACHINE\SOFTWARE\PSC\PROGRESS\9.1E\JAVA\JMVARGS to contain -ms256m -mx256m

For OpenEdge 10 bound to the 3.0A Fathom Management:
UNIX AND Windows:

edit $DLC/properties/AdminServerPlugins.properties and find following section

[PluginPolicy.Progress.AdminServer]

and set

jvmargs=-Xms256m -Xmx256m [+remaining arguements .. -Djava.awt.headless=true -Xbootclasspath/a:<fathominstall>dlc/jars/pja.jar]

3.) Go to the working directory of Fathom and delete following 2 directories: cachedata and graphcache
4.) Startup the AdminServer.

Consider revising and decreasing the amount of graph data being stored in the fathomcache database, this would include revising what is being monitored really does need to be monitored and the intervals that are being trended at.