Kbase P116185: Remote client connection attempt fails with error, no server active (704)
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  23/12/2009 |
|
Status: Verified
SYMPTOM(s):
Remote client connection attempt fails with error, no server active (704)
** There is no server active for database <database> on -H <hostname> -S <servicename>. (704)
Self Service clients disconnect and reconnect
Client server connections that are currently connected are not affected
WebSpeed remote clients do not have an issue
The servers screen in promon (R&D/1/3) show a number of servers with pending connections
Many of the auto spawned servers in promon show ports that are not in use
FACT(s) (Environment):
All Supported Operating Systems
Progress 9.x
OpenEdge 10.x
CAUSE:
On each connection attempt that fails, the broker is assigning clients to ports that show as auto in promon, but in fact are not in use. Promon shows a continued increase of pending connections to these servers that are not connected. It continues to assign servers to clients in a round robin fashion.
FIX:
To correct this problem:
1. Change the range of ports that are being set on database startup to ports that are available, that is, are not being used and also that are not in the services file. If the range of ports that you wish to use are listed in the services file and are not being used, they can be commented out instead of resetting the range.
2. And if needed, due to clients failing to make the connection to the assign server, add the -PendConnTime startup parameter to the startup of the database .