Consultor Eletrônico



Kbase P116026: Java error "Local class not compatible" when trying to connect to a remote AdminServer via Progress
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/29/2008
Status: Verified

SYMPTOM(s):

Progress Explorer

Unable to connect to Admin server from Progress explorer

Progress Explorer hangs for +/- 10 minutes and then returns a Java error

error unmarshalling return; nested exception is:
java.io.InvalidClassException: com.progress.common.networkevents.EventInterestObject_Stub; Local class not compatible

Admin server is running on Linux

PROADSV -Q says AdminServer is alive

NSMAN command works correctly

Network on the Linux machine is set correctly

There is no firewall between AdminServer and machine with Progress Explorer

A second version of Progress is installed on the Windows machine

AdminServer for the second version of Progress is Started

FACT(s) (Environment):

Linux Intel
Windows
Progress 9.x
OpenEdge 10.x

CAUSE:

A file clash is occurring causing Progress Explorer to use the wrong Java version. Since Progress Explorer must be exactly the same version as the AdminServer that it is trying to connect to then the connection fails.

FIX:

Option #1
Stop the AdminServer for the other version of Progress.
Set the Startup Type of the Service to Manual.
Reboot the PC.
Start the Progress Explorer that has the same version as the AdminServer on the remote machine.
Establish the connection.

Option #2
Uninstall the second version of Progress.
Reboot the PC.
Start the Progress Explorer that has the same version as the AdminServer on the remote machine.
Establish the connection.