Consultor Eletrônico



Kbase P115882: Trying to run prodebugenable results in an Access Denied message.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   23/02/2011
Status: Unverified

SYMPTOM(s):

Trying to run prodebugenable results in an Access Denied message.

Trying to start the debugger results in Access Denied

Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.

Trying to run prodebugenable from a Netsetup client results in a permissions error.

The prodbgtlr.log file contains:

TailoringSetup
TailoringDispatch - EnableDebug
Enable Debug
Write to registry
TailoringDispatch - changePermissions
ChangePermissions on:
S:\dlc10\bin\_debugEnable.exe
Check Operating System
File system is NTFS
Set Security
Unexpected error when trying to set permissions, errno 5.


FACT(s) (Environment):

OpenEdge 10.x

CAUSE:

The cause of the problem is that the Netsetup User is not in the Administrator group for the server machine where Progress was originally installed.


When OpenEdge is installed on the server machine, the security routine runs and it does 2 things. First, it makes an entry to the registry for debugging disabled. Then, it sets an Access control list on the file $DLC/bin/_debugEnable.exe. We give FULL access to the user performing the install (even if he's not an administrator) and to anyone in the administrators group on the machine.

When the Netsetup client tries to run prodebugenable it tries to execute the _debugEnable.exe file but because the Netsetup user is not the installer of OpenEdge on the server machine, and is not a member of the server Admin group, then the permissions error is displayed.

This is expected behavior. The debugger is behaving as designed.

FIX:

Add the Netsetup user to the Admin Group of the server machine where Progress OpenEdge is installed.