Consultor Eletrônico



Kbase P115642: All After Image extents are LOCKED by Fathom Replication and can't continue processing.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   12/31/2008
Status: Verified

SYMPTOM(s):

Switch to new ai extent failed. (3669)

All After Image (AI) extents are LOCKED.

No EMPTY AI extents are available.

Cannot add or modify any database records.

FACT(s) (Environment):

Fathom Replication 3.0A
Fathom Replication 10.x
All Supported Operating Systems

CAUSE:

There are no ai extents to switch to since they are all in the the LOCKED status (apart from the current BUSY ai extent). The reason that the ai notes have not been processed is that the Replication Server (RPLS) has lost contact with the Replication Agent (RPLA)

FIX:

STEPS:

on the TARGET machine, restart the target database
on the source machine, restart the RPLS as follows:
$ dsrutil <sourcedb> -C restart server

Once connection and synchronisation between the RPLS and RPLA have completed, the LOCKED ai files will be processed and become FULL.
As the ai files become FULL, OS back them up and then empty them:
$ rfutil <sourcedb> -C aimage empty

FURTHER ACTIONS:
- Understand why the RPLA stopped, this may be because the target machine was rebooted or network problems interfering with RPLS - RPLA communications.
- Consider adding more fixed ai extents
- start the source database up with the -aistall parameter
- Consider Fathom Management to alert when resources fail