Kbase P115620: Unable to access the SOAP-FAULT-DETAIL information in an OpenEdge 10.1A client when accessing an Ope
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  27/04/2006 |
|
Status: Unverified
FACT(s) (Environment):
OpenEdge 10.1A
OpenEdge 10.0B
SYMPTOM(s):
Unable to access the SOAP-FAULT-DETAIL information in an OpenEdge 10.1A client when accessing an OpenEdge 10.0B Web Service
Works fine when accessing the Web Service from an OpenEdge 10.0B client
CAUSE:
When a Web Services client calls an OpenEdge 10.0B Web Service that returns a SOAP fault, the HTTP status in the response is 200 (success). According to the SOAP specification it should be 500 (failure) if the SOAP message contains a SOAP fault.
The OpenEdge 10.1A client follows the SOAP specification more strictly, this causes it to access the SOAP fault without the fault detail information.
CAUSE:
Bug# 20041207-027
CAUSE:
Bug# 20050216-005
FIX:
Upgrade the OpenEdge Web Service to OpenEdge 10.1A. The Web Service will then return HTTP status 500 when there is a SOAP fault, thus making it possible for the OpenEdge 10.1A client to access the SOAP fault detail information.