Kbase P115290: CyberQuery application tries to connect as a 4GL remote client in a local loop back manner - use mul
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/13/2010 |
|
Status: Verified
SYMPTOM(s):
Cannot connect to database from CyberQuery application.
The server or the system has no more resources. Please contact Progress Technical Support.
There are 4 _sqlsrv2 processes available for users to connect.
Client connection does not make use of DSNs.
There aren't any Progress software packages installed on the client machine.
Connections are associated with an IP address in CyberQuery.
Servers are automatically detected from the CyberQuery application.
Can connect to another Progress database without a problem.
FACT(s) (Environment):
All Supported Operating Systems
OpenEdge 10.x
Progress 9.1x
CAUSE:
All remote servers are SQL server processes (_sqlsrv2). CyberQuery connects to a database in a 4GL local loop back type of connection. Because the only remote servers being spawned for the database are for SQL clients, there are no resources left to spawn a 4GL server to handle remote 4GL clients even if they are in a local loop back type of configuration.
FIX:
Spawn multiple brokers so that sufficient servers are available for SQL and remote 4GL clients or clients configured in a client/server manner.