Consultor Eletrônico



Kbase P114976: Missing prodbgtlr.dll causing error 11724 when trying to invoke the Progress Debugger
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   16/10/2008
Status: Unverified

FACT(s) (Environment):

OpenEdge 10.X
Windows NT 32 Intel/Windows 2000

SYMPTOM(s):

Getting error 11724 when trying to invoke the Progress Debugger

The Progress 4GL is not enabled for debugging. Use the proDebugEnable
tool to enable debugging and set debugger Enabled to 1 for Appservers.
(11724)

Registry entries show that the debugger has been enabled.

CAUSE:

The file prodbgtlr.dll is not on the system

FIX:

Verify that the file was never installed by looking in the installd.ini file. This file should have been installed in the <install dir>/bin directory.
If no reference of the file appears in the ini file, reinstall Progress.
If the file appears in the installd.ini then the file has been deleted by an outside source.
The file can be replaced with the prodbgtlr.dll from another installation.
The prodbgtlr.dll that is put in the <install dir>/bin directory needs to be from installation of the same mayor and minor versions of Progress.
In other words, if the missing dll file is from a Open Edge 10.0B03 installation, replace the missing file with a prodbgtlr.dll from a Open Edge 10.0B03 installation.