Kbase P113892: Cannot access the Setup routines for the Progress OpenEdge 10.1A driver ODBC driver when a NetSetup
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  4/18/2006 |
|
Status: Verified
FACT(s) (Environment):
OpenEdge 10.1A
Progress OpenEdge 10.1A driver
SYMPTOM(s):
Error messages when trying to configure the Progress OpenEdge 10.1A ODBC driver
The Setup routines for the Progress OpenEdge 10.1A driver ODBC driver could not be accessed. Please reinstall the driver.
The setup routines for the %s ODBC driver could not be accessed. Please reinstall the driver.
A NetSetup install has been performed.
The error does not occur on the local machine where OpenEdge has been installed.
CAUSE:
This is a known issue being investigated by Development.
The Setup key in the registry
HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\Progress OpenEdge 10.1A driver
is not referring to the correct DLL file.
It refers to "PGOE1021R.DLL" instead of "PGPOE1021.DLL".
FIX:
To work around the errors, follow the steps below on the machine where the NetSetup installed has been performed:
- In the registry, locate:
[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\Progress OpenEdge 10.1A driver]
- Change the "setup" key value from PGPOE1021R.DLL to PGOE1021.DLL