Consultor Eletrônico



Kbase P113860: SQLExp fails to connect when launched on Suse 9.0 system with error: No suitable driver in 9.1E FCS
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   3/22/2010
Status: Unverified

SYMPTOM(s):

SQLExp fails to connect system with error:

Error: No suitable driver. (8933)


See sqlexp.log" and "SQLExplorer.exceptions" files for more information. (8950)

SQLExplorer.exceptions contains the following stack trace:

java.sql.SQLException

Message (throw): ### Connect stack trace. ###

Message (excp): No suitable driver

Stack Trace: java.sql.SQLException: No suitable driver


nm $DLC/lib/libprocli92.so |grep __check_null_eh_spec command returns the symbol definition

FACT(s) (Environment):

Progress 9.1E
SuSe Enterprise Server 9

CAUSE:

The exact cause is unknown at the time of this writing

FIX:

Upgrade to Progress 9.1E02
As a workaround to this issue:

Use a SQLExplorer installed on another Operating System. For Example use a Progress client installed on Windows to run the SQL statements.