Consultor Eletrônico



Kbase P113740: Unable to connect to an OpenEdge database through ODBC/JDBC; server rejects connection on attach.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   07/03/2010
Status: Verified

SYMPTOM(s):

Unable to connect to an OpenEdge database through ODBC/JDBC; server rejects connection on attach.

ODBC Data Source test connect fails with error:

[DataDirect][ODBC OPENEDGE driver][OPENEDGE]Server rejects connection on attach.

Same error using SQL Explorer


[DataDirect][ODBC Progress OpenEdge Wire Protocol driver][OPENEDGE]Server rejects connection on attach.

Connecting as root using SQL Explorer is successful.

ODBC data source defined to use sysprogress account.

No entries exist in _User table, so sysprogress is inactive.

FACT(s) (Environment):

All Supported Operating Systems
OpenEdge 10.x

CAUSE:

Attempted login with invalid login credentials.


FIX:

Use the correct user credentials when connecting as a SQL-92 User.

There are two types of connections that may be made as a SQL user: authenticated and unauthenticated (users who have been granted rights by the SQL DBA).

1. SQL92 login authentication is only done if there are users in the _User table.
For example, in order for the sysprogress user to have access to the database as a SQL user, a User Account must be created with the SQL-92 CREATE USER statement or the Data Administration Security "Edit User List" tool.
If any entries have been defined, i.e. if even one user has been added to the user table (_User) in the database, then the _User table will be used to authenticate logins for both ABL and SQL.

2. Users who have been granted rights to the database by the SQL DBA are allowed access based on their user ID, but are not authenticated.