Kbase P113520: Progress Explorer can not connect to AdminServer on Linux, error 8336.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  5/5/2009 |
|
Status: Verified
SYMPTOM(s):
Progress Explorer is getting 8336 error when trying to connect to Linux host.
Unable to connect to Admin Server. Ensure Admin Server is running. (8336)
telnet <host-name> <AdminServer-port-number> works.
Progress Version on Linux host and Client match.
Progress Service Pack Version on Linux host and Client match.
Linux /etc/hosts file has the server TCPIP address on the same line as the localhost entry.
FACT(s) (Environment):
Progress 9.1X
OpenEdge 10.X
Linux Intel
CAUSE:
/etc/hosts file does not have the proper format:
Linux /etc/hosts file has the server TCPIP address on the same line as the localhost entry.
using: 127.0.0.1 localhost 111.111.1.1 Linux
Proper Format is:
127.0.0.1 localhost localhost.localdomain
111.111.1.1 Linux
FIX:
Modify the /etc/hosts file using the correct configuration format.
To correct the problem:
1. Stop the AdminServer.
2. Correct the /etc/host file using the proper format:
Modified (working) /etc/hosts file example:
127.0.0.1 localhost
111.111.1.1 Linux
3. Restart the AdminServer.