Consultor Eletrônico



Kbase P113333: Error connecting via OpenEdge 10.1A (or higher) ODBC Driver to a 10.0B OpenEdge database
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/01/2008
Status: Verified

FACT(s) (Environment):

OpenEdge 10.1A
OpenEdge 10.0B
Progress 9.x
All Supported Operating Systems

SYMPTOM(s):

Error connecting via OpenEdge 10.1A Driver to a 10.0B OpenEdge database

[DataDirect][ODBC OPENEDGE driver][OPENEDGE]Server rejects connection on attach.

Error writing msg, socket=<n> errno=<n> usernum=<n> disconnected. (796)

Using OpenEdge 10.1A driver

CAUSE:

The 10.1A ODBC OpenEdge Driver cannot connect to a 10.0B database or 9.x database. The 10.1A ODBC Driver can only connect to a 10.1A database server. The driver has been updated to a type 4 driver, which is not compatible with previous releases.
Please reference the OpenEdge 10 Platform & Product availability guide and release note 101A-00348:
JDBC/ODBC connections from 10.1A drivers is not supported to 10.0
RN#: 101A-00348
========================
Connections using the new JDBC and ODBC drivers provided in 10.1a is not supported to a 10.0 database.
These drivers can only be used against a 10.1a database server.

FIX:

Install 10.0B SQL Client Access or Client Networking to get the proper DataDirect 4.2 ODBC 32 bit OpenEdge SQL92 Driver.