Consultor Eletrônico



Kbase P113242: 10.1A or later versions of OpenEdge will fail with "Unable to establish ODBC connection" when using
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   20/08/2008
Status: Verified

SYMPTOM(s):

Unable to establish ODBC connection when using service name in DSN source

Can't connect to a database using ODBC DSN source and service name

Connection via port number works fine

[DataDirect][ODBC OPENEDGE driver]Connection refused. Verify Host Name and Port Number.

[DataDirect][ODBC OPENEDGE driver]Socket closed.

[DataDirect][ODBC Progress OpenEdge Wire Protocol driver]Connection refused. Verify Host Name and Port Number.

[DataDirect][ODBC Progress OpenEdge Wire Protocol driver]Unexpected Network Error. ErrNum = 10038

FACT(s) (Environment):

OpenEdge 10.1x
Progress OpenEdge 10.1A driver
Progress OpenEdge 10.1B driver
Progress OpenEdge 10.1C driver
All Supported Operating Systems

CAUSE:

This is an expected behavior per Release Note 101A-00344 - as service name is non-standard for the DataDirect Wire Protocol drivers.

FIX:

Use port number within your DSN configuration.