Consultor Eletrônico



Kbase P112511: OpenEdge Architect fails to connect to debugger
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   24/08/2010
Status: Unverified

SYMPTOM(s):

OpenEdge Architect fails to connect to debugger

Attempting to debug from OpenEdge Architect

Progress bar in lower right hand corner indicates debugger processing

Stack view displays 'Unavailable while not debugging.'

Debug related buttons and menu options are grayed out

Progress bar in lower right corner eventually stops

Errors are sometimes reported via alert-boxes

An error occurred when trying to establish communications for using the Debugger; Error code is: <error code>. (11628)

An error occurred when trying to establish communications for using the Debugger; Error code is: 10022. (11628)

Unable to startup PROGRESS Debugger. (4106)

FACT(s) (Environment):

OpenEdge 10.1x
OpenEdge 10.1A

CAUSE:

The OpenEdge Architect Debugger default port 9999 is in use by another process and the debugger cannot find the prodbgtlr.dll needed to obtain an alternate port

FIX:

Upgrade to OpenEdge 10.1A01 or later

Workaround:
1. Shut down OpenEdge Architect
2. Copy the prodbgtlr.dll from <OE-Install>\bin\ to <OE-Install>\oeide\eclipse\plugins\com.openedge.pdt.debug_10.1.0.00\
3. Restart OpenEdge Architect