Kbase P112390: Replicated database fails to start when Fathom remote monitoring is enabled
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  6/18/2007 |
|
Status: Verified
FACT(s) (Environment):
OpenEdge 10.0B
OpenEdge 10.1A
SYMPTOM(s):
Replicated database fails to start when Fathom remote monitoring is enabled
remote monitoring has been enabled for database: fmconfig -enable
After fmconfig -enable it is not possible to start a database enabled for replication from Progress Explorer
Access to database <db> not allowed. The database is enabled for site replication but either replication is not running, or this process is not authorized to open a replication enabled database. (10356)
** This process terminated with exit code 2. (8619)
Exception at <datetimestamp>: java.lang.NullPointerException
Message (throw): Unable to obtain site replication information.
Message (excp): null
Stack Trace:
java.lang.NullPointerException
at com.progress.juniper.admin.JAConfiguration.addConventionalArguments(JAConfiguration.java:2029)
at com.progress.juniper.admin.JAConfiguration.makeMProservCommand(JAConfiguration.java:1981)
Unable to start a database enabled for replication using dbman
Database can be started manually using proserve <db> -DBService ....
pmmgr.properties are under DLC
CAUSE:
This is a known issue. The problem is that prorepl.jar is not on the AdminServer classpath in AdminServerPlugins.properties. prorepl.jar is only on the Database plugin classpath and is ignored by Sonic.
CAUSE:
Bug# OE00125129
FIX:
Upgrade to OpenEdge 10.1B, where this issue has been fixed.
Workaround #1:
Add <full-path-to-dlc>/java/prorepl.jar to the end of the classpath property under the [PluginPolicy.Progress.AdminServer] group in $DLC/properties/AdminServerPlugins.properties, then restart the AdminServer.
Workaround #2:
Alternatively use proserve to start a database:
$ proserve <dbname> -S <port> -DBService replserv