Consultor Eletrônico



Kbase P111748: Installing WebClient or WebClient Application fails due to the imposed file size restrictions on Fir
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   12/12/2005
Status: Unverified

SYMPTOM(s):

Installing WebClient or WebClient Application fails due to the imposed file size restrictions on Firewall

Using FortiGate Firewall in front of the web server hosting the WebClient and application installation files

Installation of the WebClient fails with error: The following error occurred on the file 'prolib.exe'. Object not found (0x8004d554)

Trying to manually download data2.cab file fails with web server error

Attention!!!
The file "data2.cab" has been blocked. The file is larger than the configured file size limit.
URL = http://HostName/Webclient/data2.cab

If the client PC already has WebClient installed, then installation of the application might fail with error

Error occurred while accessing component property/method: OpenCab.
The Cabinet file does not have the correct format
Error code: 0x80020009 wcadd/_ExtractComponent.p (5890)
Application installation has been terminated.

Download of the larger WebClient application's component cab files fails with the web server error

Attention!!!
The file "<component-name>.cab" has been blocked. The file is larger than the configured file size limit.
URL = .cab">http://HostName/deployment-dir/version-dir/<component-name>.cab

CAUSE:

The Firewall blocks the access to the files larger than configured size limit.

FIX:

The Firewall configuration must be changed to allow download for adequate file size limit.
For the FortiGate Firewall, open the web configuration interface and navigate to the section
"Oversize Treshhold Configuration" and set the HTTP size to sufficiently high value (depending on the size of your cab files).
This value must be higher than 20MB to allow for all WebClient installation files to be downloadable.