Consultor Eletrônico



Kbase P111389: Getting error 8100 on the broker log file when starting 13th webspeed agent
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   16/03/2010
Status: Verified

SYMPTOM(s):

Getting error 8100 on the broker log file when starting 13th webspeed agent

ERROR: cannot start server.(8100)

Error "Timeout while listening for server: java.io.InterruptedIOException: Accept timed out" in Broker log

The WebSpeed or AppServer agent log file may also show the error 5485

Service <service_name> transport <transport_name> is busy. (5485)

Service transport TCP is busy. (5485)

FACT(s) (Environment):

Only 12 WebSpeed agents can be started with 25 agent license
Multiple defined Brokers can only start a total of 12 agents
New services file has many ports defined by IBM
Only 12 ports not listed in services file that are in the Broke range of ports
New install of AIX 5300-03
Many defined ports in the services file are not being used.
OpenEdge 10.x
WebSpeed 3.1E
WebSpeed 3.1D
IBM AIX POWER 5.3

CAUSE:

This problem was caused by the agents not being able to find enough available ports within the given port range. When an agent selects a listening port, it checks getservbyport() to see if the port is defined (in /etc/services) for a specific service. Essentially, if the selected port had an entry (e.g. 3202/tcp) in /etc/services, the agent would not use that port (even if it was not in use), and look for another port. Since there were no ports available in the range, the agent failed to start in a timely manner, and the server thread timed out.

FIX:

Remove the unnecessary entries in the /etc/service file that are within the Brokers srvrMinPort and srvMaxPort range or change the Broker's range of ports