Consultor Eletrônico



Kbase P109188: Local self service client is still locking a record after its Telnet session crashed.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   3/28/2008
Status: Unverified

SYMPTOM(s):

Same user is not visible in PROMON's User List after user is disconnected using PROMON.

Existing users in the database cannot access the locked record.

Protrace file contains the following:

Stacktrace from _progres reads:
_setuid()
csopenGetRequest()
csopenGetRequest()
csopenCancelRequests()
csopenDisconnect()
rncs_disconnect()


Local self service client process is still locking a record after its Telnet session crashed.

CAUSE:

This is a known issue being investigated by Development

FIX:

Shutting down and restarting the database broker will release all locks.