Consultor Eletrônico



Kbase P110332: Unable to start an AppServer agent using Progress Explorer
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   07/02/2009
Status: Verified

SYMPTOM(s):

Unable to start an AppServer agent using Progress Explorer

IOException reading message from server : java.io.EOFException: pipe to server broken (8117)

cannot start server. (8100)

Exception unbinding broker (not bound) : asbroker1 (8525)

Application Server Startup. (5473)

Application Server initialization failure. (5475)

Application Server Shutdown. (5476)

Server startup parameters for the AppServer are not in the correct order

FACT(s) (Environment):

Progress 9.1E
OpenEdge 10.x

CAUSE:

The -db is located after the network connection components, i.e. -H <hostname> -S <port#> -N TCP -db <dbname>. The startup parameters list network components , but no database to reference as a -db is implicitly associated with any parameters listed prior to a listed -db.

FIX:

The -db with a database name should be first in the connection statement, followed by parameters related to the connection of that database. When a second database is included, then a second -db can be used, followed by its parameters and so forth.
Re-order the startup parameters for the AppServer agent so the -db is listed first followed by a database name :
-db <dbname> -H <hostname> -S <port#> -N TCP