Consultor Eletrônico



Kbase 17495: Need xxx GB Of Disk Space To Install 8.x On/From Windows 32
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   03/06/2002
Solution ID: 17495

FACT(s) (Environment):

Progress 8.x
Windows 32 Intel
Windows NT 32 Intel/Windows 2000

SYMPTOM(s):

"Need xxx gigabytes of file space"

"Insufficient diskspace, required xxx gig; available less then yyy gig"

CAUSE:

There are three separate scenarios that cause the Progress installation software to report a need for more than one gigabyte of disk space. All scenarios are false and are caused by issues outside of the Progress installation software. In one case the installation routine will ask for exactly 2.2 gigabytes. In the other scenarios the installation software will ask for a large amount of disk space although not necessarily 2.2 gigabytes.

FIX:

UPGRADE TO 8.3C or higher. Bug # 20000215-051 was fixed in Version 8.3C.
A bypass was added to the installation utility. This allows the user to continue installing even though the installer thinks there is not enough disk space. However, there is still a danger of hitting the wall if it's too close.

FIX:

STEP BY STEP DETAILS - CASE 1
=============================
---> If the installation says that (exactly) 2.2 gigabytes of disk space is required:

This is an issue that appears only when installing to Windows 95 workstations and the installation CD-ROM disk is inserted into in another Windows 95 computer's CD-ROM drive and then connected via the network in a peer-to-peer environment.

This will also occur if sharing a directory from a Windows machine. The customer may avoid the problem by doing any one of the following:

SOLUTION - CASE 1
=================

1. Install from a CD-ROM drive that is locally installed
on this workstation (which probably is not easy to do, the
workstation probably does not have a CD-ROM drive
installed).

2. Copy the entire CD-ROM disk to a hard drive anyplace on
the network that is not a Windows 95 machine then install from that
hard drive. The CD-ROM can be copied to the local C: drive or to
any other hard drive that is accessible on the network. This will
require about 100 megabytes of space. Once the installation
is completed, the copy of the CD-ROM may be deleted.

FIX:

STEP BY STEP DETAILS - CASE 2
=============================

---> If the installation software reports that it needs more than 1 gigabyte to install but does NOT specify 2.2 gigabytes:

This is a known issue with support of long file names on Novell servers. It has only been seen on Novell. (Verify that the customer is attempting to install to a shared drive that is physically on a Novell server.) The customer can do any of the following:

SOLUTION - CASE 2
=================

1. Install to a non-Novell server or to a local C: drive.
Customers who have both Novell and NT servers may find it
easier to install to NT.

2. If the server in question is running Novell 3.11, the
customer can enable "OS/2 Long File Names Support" on the
Novell server. This is a free option in Novell, but the
default is to not install it. If the Novell support module
for OS/2 long file names is installed, the Progress
installation problem disappears.

3. If the server in question is Novell 4.10 or 4.11 the
customer will have to contact Novell or a Novell Support CNE
for assistance. Support of long file names on Novell
4.10/4.11 is reportedly a more complex procedure and is
beyond the scope of this document. Our customers report that
there are several options within Novell 4.10/4.11 related to
long file names and that several of them must be enabled.
The customer is better served if he or she contacts Novell
directly. Customers who have done this in the past report
that the Progress installation issues disappear after
enabling the the proper Novell options.

Novell KnowledgeBase document #1005596, 1007931 and 2912726 all
talk about this problem within Novell servers. Contact Novell
Tech Support to obtain further assistance.

FIX:

STEP BY STEP DETAILS - CASE 3
=============================

---> If the installation software reports that it needs more
than 1 gigabyte to install but does NOT specify 2.2 gigabyes when
installing to a Novell file server that supports long filenames:

This is a known problem when the installation is being run from a
PC that is using Novell's Client32 software. It is caused by a
Microsoft bug in GetDiskFreeSpace when used with Novell's Client32.

SOLUTION - CASE 3
=================

The workaround is to install Progress from a PC that uses Microsoft's
Client for Netware.

Another workaround is possible if there is an NT file server on the
network. You can map a drive to the NT file server using the same
drive letter you plan to use when mapping to the Novell file server.
Install to the NT file server and then move all the files in the DLC
directory and it's subdirectories to the Novell file server. Change
the drive mapping on the client PC to point to the Novell file server.
It's important to make sure the drive letter used in the Novell
mapping is the same as the drive letter used during the install to the
NT server because the drive letter is recorded in many of the entries
we make in the registry during the install.