Consultor Eletrônico



Kbase P109054: Unable to Un-install WebClient
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   16/10/2008
Status: Verified

FACT(s) (Environment):

Progress 9.x
OpenEdge 10.x
Windows

SYMPTOM(s):

Unable to install WebClient

Cannot retrieve the destination path from the registry

Error: "Cannot retrieve the destination path from the registry"

Unable to uninstall WebClient

CAUSE:

Corruption in the registry.

FIX:

To solve this problem there are 2 possibilities:
A. Correct the destination and run un-install again. The directory paths are in the registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\WebClient

B. Since the Destination Path can be correct regardless the error message, it might be necessary to manually remove the WebClient installation and the corresponding registry keys.
To manually remove the WebClient installation it's registry keys do the following (note that the directory structure used here is the default):
1. Back up the registry
2. Delete:
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\WebClient
2. b) If there was a WebClient application installed, also delete:
HKEY_LOCAL_MACHINE\SOFTWARE\WebClient
HKEY_LOCAL_MACHINE\SOFTWARE\<Vendor name>\<appname> and...
HKEY_USERS\<User ID>\Software\Vendor name>\<appname>
3. Unregister the WebClient DLL's located in:
C:\Program Files\Common Files\Progress Software
(prox.dll, psccab.dll and pscsecreg.dll)
To unregistered run:
regsvr32 /u prox.dll
regsvr32 /u psccab.dll
regsvr32 /u pscsecreg.dll
4. Then delete the directories:
C:\Program Files\Common Files\Progress Software
C:\Program Files\Progress Software\WebClient
C:\Program Files\WebClientApps