Kbase P109042: Debugger listing not found when attaching debugger to batch client
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  26/05/2010 |
|
Status: Verified
SYMPTOM(s):
Debugger listing not found when attaching debugger to batch client
No Debugger listing file available for <procedure>. (3071)
No Debugger listing file available for <random series of characters>. (3071)
Procedure compiled without debug listing option
FACT(s) (Environment):
Attaching debugger to batch client
Batch client running on remote machine from debugger
OpenEdge 10.x
Windows
CAUSE:
When the r-code is generated, debugging information is saved into the debugger segment.
If a debug-list is specified, the name for the debug-list is included in this information. Otherwise, when the debugger is started an attempt is made to generate a temporary debug-list with a random file name on the machine doing the compile.
The debug-list has to be available on the machine where the debugger is running. So unless this has direct access to the batch client's temp files - which is usually impossible due to file sharing and/or permission issues - it will not be able to find this temporary debug-list even if it is successfully generated.
FIX:
Compile the r-code using the debug-list option, and store the generated debug-list in a location accessible to the debugger.