Kbase P108713: WebSpeed Agent fails to start staying in 'STARTING' status
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  16/10/2008 |
|
Status: Verified
SYMPTOM(s):
WebSpeed Agent fails to start staying in 'STARTING' status
Webspeed Broker log shows error:
Timeout while listening for server : java.net.SocketTimeoutException: Accept timed out
ERROR: cannot start server. (8100)
Webspeed Server log shows error:
WTA: npp_enable_connections() failed with error number: -12. (6396)
FACT(s) (Environment):
All Supported Operating Systems
WebSpeed 3.x
Progress 9.x
WebSpeed 10.x
CAUSE:
Error number -12 means "NO_AVAILABLE_PORT". The TCP port range for the WebSpeed agents are occupied by other processes (often Agents from a different WebSpeed Broker)
If the TCP port range for the WebSpeed Agents, defined by srvrMaxPort and srvrMinPort, is too small or is being used by other Agents or processes the Broker will not be able to spawn new Agents.
FIX:
Change the port range used by the agents making the range bigger or define different port ranges for each WebSpeed broker.
To make the modification, edit manually ubroker.properties file or using Progress Explorer:
In Progress Explore go to Broker properties -> Agent -> General:
The port range is defined by the 'Minimum Port Number' and the 'Maximum Port Number'
To alter manually in ubroker.properties use the following parameters for the WebSpeed Broker definition:
srvrMaxPort=
srvrMinPort=