Kbase P108401: Trying to connect remotely to a database with sqlexp on 10.x gives error [JDBC OpenEdge Driver]:[201
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/22/2008 |
|
Status: Verified
SYMPTOM(s):
Trying to connect remotely to a database with sqlexp gives error
java.sql.SQLException
Message (throw): ### Connect stack trace. ###
Message (excp): [JDBC OpenEdge Driver]:[20101]No Data
Stack Trace:java.sql.SQLException: [JDBC OpenEdge Driver]:[20101]No Data
Database log file shows error 1280
Connection timed out on socket=<n> for usernum <n>, attempt disconnect. (1280)
Client and database are on the same machine
FACT(s) (Environment):
Sun Solaris SPARC
OpenEdge 10.x
Progress 9.x
CAUSE:
A 9.x client cannot connect to a 10.0x database. The error 1280 is being output to the database log instead of a message indicating that there is a version mismatch.
FIX:
Connect to the 10.0x database with a 10.x client. If the client is 10.0x, check to see if there is a 9.x client installed on the machine. If so, check to see if the LD_LIBRARY_PATH environment variable has any references to 9.x. Remove any such references.