Consultor Eletrônico



Kbase P107734: Error 8184 and FathomTrendingUnavailable alert in admserv.log
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   16/06/2006
Status: Unverified

FACT(s) (Environment):

Fathom Management 2.X
Fathom Management 3.X
Progress 9.1D
Progress 9.1E
OpenEdge 10.0B

SYMPTOM(s):

Problem with trend data, see admserv.log on trend machine: (9640)

Getting alert FathomTrendingUnavailable from Fathom Console

Fathom cannot reach the trend database at jdbc:jdbcprogress:T:localhost:12345:fathom. Check the log file for more information. (9892)

admserv.log reads:
An SQL Exception occured during an insert into the trend database. SQLState: HY000
message: [JDBC Progress Driver]:Character string is too long (8184)
vendor: -20152
statement: INSERT INTO PUB.Cf_Status values (209,'mycontainer','8/15/2005',18014,'The SQL engine Statement Manager statement cache overflowed. {0} statements are currently in use ({1} cache). (9799)',263670,'' ) (9494)

CAUSE:

Errors above say that Fathom Framework has blown up the 100 prepared statements cache and was trying to store that information into Fathom Trend database, which has failed due to SQL-WIDTH improperly set for cf_status.status_status field.

FIX:

Connect to Fathom Trend DB -> Data Dictionary -> cf_status -> Options -> Adjust SQL properties and increase width for Status_status field to 200.
You will need the username= guest and password=guest

Additionally, the fathom database startup parameter -SQLStmtCache can be set to 300 in order to increase the number of cached prepared statements, so the original error will not happen again. (Database has to be restarted in order to apply -SQLStmtCache parameter)