Consultor Eletrônico



Kbase P107458: Server did not respond error when connecting via JDBC/ODBC caused by wrong port number or port name
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/24/2008
Status: Verified

SYMPTOM(s):

Error attempting to connect to a Progress Database via ODBC/JDBC

Error:
[JDBC OpenEdge Driver]: Server did not respond

Error in DataServer log file

MsgFormatException received on client connection : <MsgFormatException_string> <MsgFormatExceptionMsg_string>. (8083)

FACT(s) (Environment):

UNIX
Windows
OpenEdge 10.x

CAUSE:

The port being specified in the ODBC/JDBC connection configuration is able to service a SQL connection. This can be due to a database broker being configured for only 4GL connections or the client specifying a Appserver/Dataserver/Webspeed port.
If the client is connecting to a DataServer port, the following error message can be seen the the DataServer log file:
MsgFormatException received on client connection : <MsgFormatException_string> <MsgFormatExceptionMsg_string>. (8083)

FIX:

Make sure the port being specified in the connection configuration of the ODBC or JDBC client for the appropriated _mprosrv process that supports SQL connections.