Consultor Eletrônico



Kbase P106799: Can not shut down a progress database
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   16/10/2008
Status: Verified

FACT(s) (Environment):

SuSe Enterprise Server 8
Windows XP
Windows 2003

SYMPTOM(s):

Can not shut down a progress database

proshut only gives:

Shutdown is executing. (1613)

Using telnet to a "older" Linux system from a client system with stateful packet filtering firewall enabled.

The same problem can happen when using ssh client connection to the server

The "older" Linux system uses inetd / tcpd to parse incoming connections
to the telnet daemon.

CAUSE:

Older Linux distributions like SuSe Enterprise Server 8 uses inetd as a tcp wrapper, tcpd
is called in order to decide if the client is allowed to log in as per hosts.allow / hosts.deny
and in case the incoming connection is allowed, tcpd parses the session to the telnet
daemon. Older versions of tcpd do not like stateful packet filtering firewalls so the
telnet connections is handled incorrectly although connection is parsed to the telnetd
daemon and the user can login after some seconds delay. This results in incorrect
behavior on the Progress database, i.e does not start properly and can not be
shut down.

FIX:

There are several workarounds:

1) Do not use tcpd (functionality can be implemented with firewall rules instead):

Replace:

telnet stream tcp nowait root /usr/sbin/tcpd in.telnetd

With:

telnet stream tcp nowait root /usr/sbin/in.telnetd in.telnetd

In /etc/inetd.conf and restart the inetd deamon.

2) Initiate a telnet localhost once logged in to the system.

3) Do not use a firewall on the client side.