Kbase P106654: Corrupt data in InstallShield Installation Information folder causes Progress install to fail
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  9/16/2005 |
|
Status: Unverified
FACT(s) (Environment):
OpenEdge 10.x
Windows 2003
SYMPTOM(s):
Unable to install OE 10.0B Workgroup Database product
Unable to uninstall OE 10.0B Personal Database product
InstallShield hangs soon after setup.exe is launched
Manually removing all OE 10.0B entries for Progress Personal Database product from Windows registry does not help
Removing Progress uninstall file (ProgressUninstall9.1D) from Windows directory does not help
OE 10.0B installation still hangs
CAUSE:
InstallShield Installation Information folder contains corrupt data. InstallShield creates an archive of its installers under Window's Progress Files in a folder labeled InstallShield Installation Information.
The folder contains information about the particular product that has been installed. The folder name or GUID is written to the registry under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Management\ARPCache.
FIX:
1. Go to Windows Start menu
2. Run regedit
3. Select HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Management\ARPCache
4. Delete the GUIDs or folder that match the ones listed in the InstallShield Installation Information folder under the Program Files
For example the InstallShield Information folder shows the following GUID:
{1E48D50B-D507-11D3-B4BF-00104B311D5E}
Under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows|CurrentVersion\App Management\ARPCache the same GUID will be recorded. Delete the GUID.