Kbase P106636: WS Broker hung in STARTING status when license is not registered at registry
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  15/03/2010 |
|
Status: Verified
SYMPTOM(s):
Can not start Webspeed Broker
WebSpeed Broker hanging at "STARTING" status
ERROR: cannot start server. (8100)
Timeout while listening for server : java.io.InterruptedIOException: Accept timed out
Exception unbinding broker (not bound) : wsbroker1 (8525)
No errors in server log file
Registration key HKEY_LOCAL_MACHINE\Software\PSC\{license}\{version}\Install Type does not show provision license
Registration key HKEY_LOCAL_MACHINE\Software\PSC\{license}\{version}\Install Type shows other licenses
FACT(s) (Environment):
WebSpeed 3.1D
Windows NT 32 Intel/Windows 2000
Adminserver is alive
NameServer is alive
Uses ubroker.properties.template
Cfg shows provision license together with other licenses
provision license is the only license that enables WebSpeed
CAUSE:
The provision license is not registered in registry though it is written to progress.cfg
FIX:
Uninstall and reinstall Progres on the machine
1. Shut down running progress process.
2. Uninstall Progress through the Uninstall Shield
3. Reinstall Progress