Kbase P106350: AdminServer server fails to start on Windows 2003 SP1 and Windows XP SP2
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/11/2010 |
|
Status: Verified
SYMPTOM(s):
The AdminServer server fails to start on Windows 2003 SP1 and Windows XP SP2
Cannot connect to AdminServer with Progress Explorer
Unable to connect to Admin Server. Ensure Admin Server is running. (8336)
Windows boot up gives java errors
Failing Application java.exe version 0.0.0.0, faulting module jvm.dll, version 0.0.0.0, fault address XxXXXXXXX
To protect your computer, Windows has closed this program. Program: JAVA
Data Execution Prevention: Microsoft has closed this program java.exe
FACT(s) (Environment):
Adminserver is running in Services
proadsv -query returns to prompt with no message
No java processes in Task Manager
No AdminServer log files are created.
OpenEdge 10.1C03 Service Pack
Windows 2003
Windows XP
Windows 2008
CAUSE:
Microsoft's Data Execution Prevention or DEP is preventing java from launching. The AdminServer runs under a JAVA process. If JAVA can not start the AdminServer will not start.
If the Adminserver is set to Autostart in Services, as is the default setting, it will try to launch java.exe on bootup and the error will occur.
FIX:
Turn off DEP for the JAVA process. This will allow JAVA to start which will allow the AdminServer to start.
1. There is an option in the pop up message on Windows reboot to change settings for DEP to allow java.exe to run.
2. If the pop up window is no longer displayed you can access the DEP setting by right clicking on:
a) Right click on My Computer icon
b) Select Properties
c) Select the Advanced tab
d) Click on Performance box, click on Settings
e) Click on the Data Execution Prevention tab
f) Select "Turn on DEP essential Windows programs and services only".