Consultor Eletrônico



Kbase P106348: Java error posted when trying to connect to AdminServer in Progress Explorer Tool
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   7/20/2005
Status: Unverified

FACT(s) (Environment):

Progress 9.1E
Windows 2000

SYMPTOM(s):

Java error posted when trying to connect to AdminServer in Progress Explorer Tool

Java error recorded in adc0.exp log file
java.lang.Exception: com/progress/ubroker/tools/AbstractGuiPluginRemObj_Stub
at com/progress/vj/explorer/ProgressServer.setupPlugins
at com/progress/vj/explorer/ProgressServer.workingCallback2
at com/ms/lang/Delegate.dynamicInvoke0
at com/ms/lang/Delegate.dynamicInvoke
at com/ms/wfc/ui/Control.invokeMarshaledCallback
at com/ms/wfc/ui/Control.wndProc
at com/ms/wfc/ui/Form.wndProc
at com/ms/wfc/app/Application$ParkingForm.wndProc
at com/ms/wfc/ui/Control$ControlWindow.wndProc
at com/ms/wfc/app/Window.callback


Installd.ini file shows a complete installation performed

Replacing the ubroker.properties file with the ubroker.properties template does not resolve issue

Replacing the ubroker.properties file with Progress 9.1E ubroker.properties template from another Windows 2000 system does not resolve the issue.

Registry keys point to the installation directories

Progress Java entries in registry match Java entries on a working 9.1E version on another Windows 2000 system.

CAUSE:

The AdminServer is unable to load the Plugins.

FIX:

To resolve the problem:
1. Remove Progress installation
2. Check the registry to ensure all Progress files have been removed
3. Reboot the Windows 2000 system
4. Reinstall Progress