Kbase P106258: 4GL/ABL: Error (11724) using the 4GL/ABL Debugger
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  04/05/2010 |
|
Status: Verified
SYMPTOM(s):
4GL/ABL: Error (11724) using the 4GL/ABL Debugger
The Progress 4GL is not enabled for debugging. Use the proDebugEnable tool to enable debugging and set debugger Enabled to 1 for AppServers. (11724)
proDebugEnable has been executed prior starting debugging session
Unable to run Progress debugger
Progress has been installed locally
Using local installation only, the debugger works
Using ini file within the same installation, debugger does not start
The ini file points to a different installation on a share drive
FACT(s) (Environment):
Windows
OpenEdge 10.X
CAUSE:
The Progress binds debugging to a single drive and creates an appropriate registry entry with a drive in it. Since second session (with ini file) is using a different drive, the debugging information (session has been enabled for debugging) is missing from the registry.
FIX:
There are 2 ways how to fix this problem:
1) run "regedit" and go to HKEY_LOCAL_MACHINE\SOFTWARE\Secure\ProDbgCK and create another entry there - similar to other entries, but with "p:\v100b.state" without "" as a value name, with "Debugging enabled" as a data. The "P:" represents a drive used by the installation on a shared drive.
2) run "proenv" within the local installation, set DLC same way as it is set for the shared installation, eg "set DLC=p:\v100b" and enable debugging again (proDebugEnable -enable-all) now for the another DLC.