Consultor Eletrônico



Kbase P100575: Get too many 6383 errors with WebSpeed
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   25/05/2010
Status: Verified

SYMPTOM(s):

Get too many 6383 errors with WebSpeed

Agent did not return an HTML page (6383)

FACT(s) (Environment):

The maximum server instance is set to 5
The error happens in a moderate to a busy time of the day
The WebSpeed agents do not stay in busy status for long at all
The web application logic assigns a unique-id session to the database for every user who browses the items in the catalog.
Have a shopping cart application as well
OpenEdge 10.x
WebSpeed 3.x
All Supported Operating Systems

CAUSE:

In this case this error happens when the record lock timeout occurs. The lock wait timeout (-lkwtmo) on WebSpeed is 10 seconds by default. When a wait on a record times out, the client (in this case, the agent) raises a STOP condition, which will cause the current program to stop (with no messages). WebSpeed catches this in the dispatcher (web-disp.p), so the agent never completely stops, it just sits waiting for the next request to come in.

FIX:

There are two workarounds suggestions for this problem:
1. Change the application logic to assign the unique session-id only when the user adds the catalog item(s) to the shopping cart. This will minimize the unnecessary database transaction in case if the user is just browsing the catalog for different items.
OR
2. Increase the lock wait timeout by using the *-lkwtmo* to more then 10 seconds.
The later work around may reduce the number of errors but would not be a complete solution to rid the problem.