Consultor Eletrônico



Kbase P105539: WebClient application upgrade fails when trying to download the version diff cab file
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   21/06/2005
Status: Unverified

FACT(s) (Environment):

Windows NT 32 Intel/Windows 2000
Progress 9.1x
OpenEdge 10.x

SYMPTOM(s):

WebClient application upgrade fails when trying to download the version diff cab file

Cab file specified in the error message does not exist in the deployment directory

The specified error points to the component cab file with the name having more than 1 version difference

Couldn't download application component: 28/diffs/START25to28.cab from Web Server with URL:
http://example.progress.com/myapp/ Error code is 2
Application upgrade has been terminated.


Other cab files for the specified component do exist: 28/diffs/START25to26.cab, 28/diffs/START26to27.cab and 28/diffs/START27to28.cab

CAUSE:

Error in generated prowcapc file due to the manual changes to the WebClient
Application Assembler's project (.wcp) file.

FIX:

Manually edit the WebClient application's project file (appname.wcp) and locate the
section where the updates are being written, e.g. :

[25Updates]
START=28/diffs/START25to28.cab

Modify all relevant sections to contain one version diff cab file name, e.g.:

[25Updates]
START=28/diffs/START25to26.cab
...
[26Updates]
START=28/diffs/START26to27.cab
...
[27Updates]
START=28/diffs/START27to28.cab

Regenerate the last application version package and re-deploy.