Kbase P105130: Fathom.lg file contains many 8841 error messages
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  08/06/2005 |
|
Status: Unverified
FACT(s) (Environment):
Fathom Management
UNIX
SYMPTOM(s):
Fathom.lg file contains many 8841 error messages
SQL server process terminated. (8841)
admserv.log shows "Database not started"
[FATHOM] connect failure to jdbc:jdbcprogress:T:<hostname>:<port>:fathom: [JDBC ProgressDriver]:[2010] Database not started
The FathomTrendDatabase is started
AdminServer started as non-root account
CAUSE:
SQL server process terminated. (8841) is being recorded for every every poll connection attempt to the fathom database, which means that we can't establish jdbc connection in order to write the polling info to a database. The fathom.db IS started, we just can't connect to it. When the AdminServer is started as non-root account, the permissions on the fathom.db files need to be adjusted so that the non-root user has read-write access.
FIX:
1.) Stop the FathomTrendDatabase
2.) Change the permissions on the fathom database files to 666 if owned by root group systemor 664 if owned by the non-root user