Consultor Eletrônico



Kbase P104903: DATADIRECT 4.20 32-BIT Progress SQL92 v10.0B driver is not available on NetSetUp client
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   11/12/2005
Status: Unverified

FACT(s) (Environment):

OpenEdge 10.0B
Windows NT 32 Intel/Windows 2000

SYMPTOM(s):

Netsetup installation will not add the SQL Client Access

DATADIRECT 4.10 32-BIT Progress SQL92 v10.0B driver is not available on NetSetUp client

Cannot see ODBC driver for Progress 10.0B client after installation

Unable to setup ODBC connection to Progress under ODBC32 Administrator on the client

The PGPRO1019.DLL is present under %DLC%/bin directory on the Server machine

No errors reported during NetSetUp

CAUSE:

Bug# 20050531-004

CAUSE:

The install routine has not created registry key for DataDirect/Merant driver on the Client's machine.

FIX:

Apply Service Pack 10.0B03 or later.
After applying the service pack on the file server, redo the NetSetup on the NetSetup clients to ensure registry keys are properly created.

If installing 10.0B03 or later is not possible, then copy following lines as xx.reg and import the xx.reg into your registry via regedit. First please alter path to your Progress installation (eg: F:\\10.0B = <mapped drive>:\\<value of %DLC%>. The driver will then be accessible. Exclude <begin> and <end> lines.

<begin>
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\DATADIRECT 4.20 32-BIT Progress SQL92 v10.0B]
"APILevel"="1"
"ConnectFunctions"="YYN"
"CPTimeout"="60"
"Driver"="F:\\10.0B\\DLC\\bin\\PGPRO1019.DLL"
"DriverODBCVer"="4.20"
"FileUsage"="0"
"Setup"="F:\\10.0B\\DLC\\bin\\PGPRO1019S.DLL"
"SQLLevel"="0"
"UsageCount"="1"
[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\ODBC Drivers]
"DATADIRECT 4.20 32-BIT Progress SQL92 v10.0B"="Installed"
<end>