Kbase P104584: Errors 5467, 5468 and 5537 connecting to AppServer, error 293 in the AppServer log file.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  14/05/2010 |
|
Status: Verified
SYMPTOM(s):
Connection refused by Application server (5467)
<procedure name> <procedure type> procedure ended with an ERROR condition. (8025)
Errors 5467, 5468 and 5537 connecting to AppServer, error 293 in the AppServer log file.
Application server connect failure. (5468)
Server is not connected. (5537)
Error 5467 and 5468 testing connection using Appserver information icon from protools
Error 8025 in the Server log file
<procedure name> Connect procedure ended with an ERROR condition. (8025)
Unable to connect to the Appserver for the <servicename> service.
Unable to connect to the Appserver for the asbroker1 service.
Could not access connection to AppService <servicename>.
Could not access connection to AppService asbroker1.
After a connection failure, the following errors appear in the AppServer server.log file:
** "<file-name>" was not found. (293)
** <procedure name> was not found. (293)
Connection failure for host <host_name> port <port> transport <transport_name>. (9407)
<file-name> in error 293 and <procedure-name> in error 8025 refer to the same file.
FACT(s) (Environment):
All Supported Operating Systems
Progress 9.x
OpenEdge 10.x
Broker starts just fine
Using procedures in the Advanced features for the appserver broker configuration
CAUSE:
Connect Procedures could not be found. The key error message is 293, which indicates that the Connect procedure specified in the AppServer properties could not be executed. That is usually because such procedure does not exist, is not accessible due to permission problems, or is not in the AppServer's PROPATH.
FIX:
Make sure that the connect procedures can be found by ensuring that the Connect procedure specified in the AppServer properties does exist, is accessible by the OS user that started up the AppServer, and that it's in the AppServer's PROPATH.
Set the PROPATH environment variable so all files needed for the application can be found via Progress Explorer Tool or editing ubroker.properties file. Find the AppServer entry having the problem and make sure there is an entry "PROPATH=<Directory path to application files>"
Example: PROPATH=C:\ApplicationFiles;C:\MoreAppFiles;@{WinChar Startup\PROPATH};@{WorkPath}With regard to permissions, please keep in mind that Windows poses restrictions on the ability to access network drives and UNC paths of user LocalAccount; other accounts might need changes to their set of permissions too. If you think this is your case, please look at Solution 19244 and other Solutions on the subject.